Author Topic: Error: Divergence detected in AMG solver: x-momentum  (Read 6288 times)

Offline pitney1

  • Jr. Member
  • **
  • Posts: 62
  • Reputation: +0/-0
  • Searching for solution
    • View Profile
Error: Divergence detected in AMG solver: x-momentum
« on: February 11, 2012, 01:11:52 PM »
Advertisement
Why am I getting divergence on the first iteration for an axisymmetric problem?

I am running a 2d axisymmetric simulation but it diverges on the first iteration with the following message:

Divergence detected in AMG solver: x-momentum -> Increasing relaxation sweeps!

Error: Divergence detected in AMG solver: x-momentum
Error Object: #f


Offline william

  • Full Member
  • ***
  • Posts: 151
  • Reputation: +14/-0
  • Know it, share it.
    • View Profile
Re: Error: Divergence detected in AMG solver: x-momentum
« Reply #1 on: February 11, 2012, 01:13:47 PM »
One reason could be that the geometry is not correct. Do a Mesh->Check to make sure you don't get

Checking for nodes that lie below the x-axis.
WARNING: Invalid axisymmetric mesh: 6 nodes lie below the x-axis.

and
WARNING: Mesh check failed.


For axisymmetric, the axial direction should be x and radial is positive y. Even if the y starts with -1e-32, it will fail.

To fix this:
Use Mesh->Translate and move the geometry so ymin is +ve.

Offline zeybi1604

  • Newbie
  • *
  • Posts: 1
  • Reputation: +0/-0
  • Searching for solution
    • View Profile
Re: Error: Divergence detected in AMG solver: x-momentum
« Reply #2 on: March 13, 2012, 06:03:55 PM »
Hello. i am doing a multiphase simulation in a packed bed using the mixture model. the volume fraction used was 0.5316.i keep getting the error message "divergence detected in AMG solver: x-momentum" for all the different solvers used and i even changed the under relaxation factors. i really have no idea how to proceed with this simulation!plzz help!thank u.

Offline william

  • Full Member
  • ***
  • Posts: 151
  • Reputation: +14/-0
  • Know it, share it.
    • View Profile
Re: Error: Divergence detected in AMG solver: x-momentum
« Reply #3 on: March 13, 2012, 08:06:20 PM »
Please try running the simulation in transient mode and set the time stepping method to adaptive.