Author Topic: Error: mpirun_mpid version mismatch  (Read 661 times)

Offline infocfd

  • Newbie
  • *
  • Posts: 37
  • Reputation: +0/-0
  • Searching for solution
    • View Profile
Error: mpirun_mpid version mismatch
« on: May 13, 2012, 10:46:41 AM »
Advertisement
When trying to launch CFX 14 in parallel you get the following error: Error: mpirun_mpid version mismatch.

Please help.

Offline william

  • Full Member
  • ***
  • Posts: 151
  • Reputation: +14/-0
  • Know it, share it.
    • View Profile
Re: Error: mpirun_mpid version mismatch
« Reply #1 on: May 13, 2012, 10:47:32 AM »
CFX Distributed Parallel in ANSYS CFX 13 uses HP-MPI while CFX Distributed Parallel in ANSYS CFX 14 uses PCMPI. These different installations of MPI can have a conflict when installed on the same Windows machine. To avoid such a conflict, be sure to follow the installation instructions that appear during Platform MPI installation. "

The only workaround is to unset or delete MPI_ROOT. This should allow CFX-13.0 and CFX-14.0 to run independently.


To Remove this Variable

Open up Control Panel > System > Advanced > Environment Variables. The MPI_ROOT will be in the System Variables. Delete this variable.